Register
Results 1 to 6 of 6
  1. #1
    gripper
    Join Date
    Jan 2017
    Location
    Brunei
    Posts
    7

    200sx

    Hi guys!

    my 200sx is using a r33 gtst 4pot front and 2pot rear.

    now my question is i have already change my master pump on rebuild kit and braided line but my braking is not functioning well. seems like there is more air inside the brake pump. we've try to bleed few time. but the result is still the same.

    can anyone guide me?

  2. #2
    dorifto kingu!
    Join Date
    Nov 2007
    Posts
    2,634
    What did you change the master cylinder for?

    Do you still have ABS?

  3. #3
    LOOSE!
    Join Date
    Apr 2010
    Location
    Welwyn
    Posts
    1,687
    I had a problem bleeding up a master cylinder which had been sat empty for a while, I can't remember exactly what the fault was but the brakes just wouldnt bleed up until I removed the master cylinder and reassembled the master cylinder piston, which didn't take long. I bled the master cylinder on the bench and then bled up all the brakes absolutely fine. Mine is a standard PS13 master cylinder with R33 GTST brakes all round.

    If i remember rightly an o-ring on the master cylinder piston had slipped or needed replacing - it wasn't producing the correct pressure so the the brake pedal always felt spongey..
    PS13 K's x LOOSE
    UP ALL NIGHT GOT DEMONS TO FIGHT

  4. #4
    gripper
    Join Date
    Jan 2017
    Location
    Brunei
    Posts
    7
    im not using ABS anymore, have been remove when i install my new ECU (Adaptronice E420d)

  5. #5
    gripper
    Join Date
    Jan 2017
    Location
    Brunei
    Posts
    7
    Quote Originally Posted by Ollie View Post
    I had a problem bleeding up a master cylinder which had been sat empty for a while, I can't remember exactly what the fault was but the brakes just wouldnt bleed up until I removed the master cylinder and reassembled the master cylinder piston, which didn't take long. I bled the master cylinder on the bench and then bled up all the brakes absolutely fine. Mine is a standard PS13 master cylinder with R33 GTST brakes all round.

    If i remember rightly an o-ring on the master cylinder piston had slipped or needed replacing - it wasn't producing the correct pressure so the the brake pedal always felt spongey..
    Hi ollie

    yes indeed the o-ring on my master cylinder is slipped and i have change it with the rebuild kit along with the piston at the master cylinder pump. i would have it try again to bleed it out this weekend. hope it goes well..

  6. #6
    gripper
    Join Date
    Jan 2017
    Location
    Brunei
    Posts
    7
    Quote Originally Posted by r3k1355 View Post
    What did you change the master cylinder for?

    Do you still have ABS?
    Hi r3k1355

    i bought the r33 gtst brake kit from halfcut and they even give me the R33 gtst master cylinder. thats is why i have change it from my previous oem 200sx master cylinder. and talking about ABS, while i install my new adaptronic e420d ECU, the tuner had it remove. does it make any change is i remove my ABS?

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •