CA18DET smoking, Turbo or Valve Stem Seals...?

Thread in 'Technical Questions' started by Badger0068, Jan 19, 2012.

  1. Badger0068

    Badger0068 Member

    Joined:
    Mar 19, 2010
    Posts:
    664
    Likes Received:
    0
    Location:
    Ashford, Kent
    Recently did an oil change on my S13 and since then its been smoking quite badly. It smokes a fair bit on start up, white/light blue smoke but it doesnt smoke when I put my foot down. However when I let off it smokes quite a lot. It still smokes when the engine is nice and warm when I let off or when it idles.
    I've asked around and a few people have said its the turbo on its way out, others have said valve stem seals.
    Anyone got any ideas?
     
  2. 4_Stroke

    4_Stroke Member

    Joined:
    Jul 29, 2011
    Posts:
    414
    Likes Received:
    0
    Location:
    Leicester
    It may seem a daft question but have you overfilled the engine with oil?
     
  3. Badger0068

    Badger0068 Member

    Joined:
    Mar 19, 2010
    Posts:
    664
    Likes Received:
    0
    Location:
    Ashford, Kent
    I thought that at first but I checked it and it seems at a perfect level.
     
  4. madmandan91

    madmandan91 Member

    Joined:
    Jun 20, 2010
    Posts:
    175
    Likes Received:
    0
    Location:
    Ashford
    check turbo for play (excessive) and check exhaust outlet for damp oil if possible check before compressor and after. we have it alot at work where a customers had an oil change and since then there car smokes. and its always the turbo every time. the new oil washes away the shit from the old and then seeps through the seals.
     

Share This Page