ca18det wiring help needed plx

Thread in 'Project Cars and Builds Threads' started by Bigdave2000, Jul 16, 2015.

  1. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    hi guys im building a rx8 with a ca18det and haveing a few problems with the wiring up the ca18de ecu any 1
    able to give me a bit of advice cheers
     
  2. Chunky Nugget

    Chunky Nugget honkeytits!!

    Joined:
    Feb 16, 2006
    Posts:
    1,855
    Likes Received:
    11
    Location:
    Aldershot
    Firstly, yor a legend, CA is a true man engine.

    You only need to connect 4 wires to make it run.

    These are on the F10 and F8 plug, the big brown and grey one. I cant be arsed to use photo bucket but google S13 F10 connector you will see the one

    F10 connector the brown one

    brown wire = 10amp fused power to lambda sensor

    black/pink = fuel pump switching earth to ECU ( connect to ECU at pin 18 i think)


    F8 the grey plug

    big red wire: needs power from the battery. I think its top right as you look at it

    black and red wire: 12v feed for the ignition coils, i think it's bottom left

    That's it, and it will run like a badass.
     
  3. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    Thanks for the advise mate just waitin for my ecu to turn up then I'll give it a go
     
  4. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    Done all the wiring how u sed not getting a spark any ideas mate
     
  5. sxnutter

    sxnutter Member

    Joined:
    Mar 10, 2012
    Posts:
    221
    Likes Received:
    1
    Location:
    cleethorpes
    Just put the ecu pinouts on technical. Engine and drive train. Might help you [emoji106]
     
  6. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    Got spark now mate but no injectors to fire any ideas
     
  7. mospin

    mospin Active Member

    Joined:
    Jun 10, 2009
    Posts:
    1,731
    Likes Received:
    3
    Location:
    hertfordshire
    have you earthed the coilpack
     
  8. scouse

    scouse Active Member

    Joined:
    May 9, 2009
    Posts:
    1,000
    Likes Received:
    0
    Location:
    liverpool
    Did you buy this as a complete package from a running car or just parts?.
    if it is from parts you do have a drop resistor fitted don't you? it's a silver box about the size of a mars bar
    with a short bit of wiring and a plug,without this the injectors wont fire I don't think.

    http://thumbs.ebaystatic.com/d/l225/m/m5HWMC57MlCXn8X-HL_cKgg.jpg
     
    #8 scouse, Jul 21, 2015
    Last edited: Jul 21, 2015
  9. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    Lost spark as well now mate really picklen my brain any ideas and yer compleat package
     
  10. Bigdave2000

    Bigdave2000 Member

    Joined:
    Dec 14, 2013
    Posts:
    131
    Likes Received:
    0
    Location:
    Gloucester
    Cheers for all ur help guys all running now it had no power to the Injectors
     

Share This Page