E36 - M52 Engine swap and auto to manual - wont run!

Thread in 'Technical Questions' started by antz, Aug 15, 2015.

  1. antz

    antz Active Member

    Joined:
    May 8, 2007
    Posts:
    174
    Likes Received:
    63
    Location:
    north yorkshire
    Hi all,

    I've got a baffling problem with my E36 328i and hopefully someone can tell me what on earth is up with it.

    Its a 328i automatic with an Aug-95 build date. I swapped out the original engine and autobox for a replacement M52B28 and manual Getrag box from a 1997 E36 328i that I saw running the day before I bought it.

    I used the engine bay loom from the donor car to keep it simple
    Took the yellow/blue and green/yellow wires and extended these to a 2 pin connector for the reverse lights.
    Took the brown/black wire and spliced this into the yellow/black wire from the EWS box to bypass the starter inhibitor.
    Fitted a remapped ECU from bmwspareparts with EWS delete

    But it wont run.

    When I flick the key I have fuel pump priming, a relay in the fuse box clicks, I can hear the starter solenoid click, there's power to the starter but it just doesn't crank over!

    I've checked all my wiring connections many times and the only wires not hooked up are a two pin connector on the engine loom which I was told is for ACS that I don't have and a big circular connector on my car loom I was told is for the autobox because my old loom engine loom has two connectors and my new engine loom only has one. They are impossible to mix up too so its definitely not in the wrong one.

    Has anyone got any ideas? Im completely lost....

    [​IMG]
     
  2. LiamE36

    LiamE36 Active Member

    Joined:
    Sep 25, 2011
    Posts:
    1,525
    Likes Received:
    0
    Surely if you can here the starter solenoid clicking but not turning the engine then the starter motor is fucked? Or just a sticky solenoid? Tried the usual stuff? Giving it a wack etc.

    And as for bypassing EWS why have you spliced extra wires into it? To bypass EWS you just cut the two wires (green/black & yellow/black) behind the module and join them together.
     
  3. antz

    antz Active Member

    Joined:
    May 8, 2007
    Posts:
    174
    Likes Received:
    63
    Location:
    north yorkshire
    Sorted it! Cleaned the earth strap and redid my ews wiring bypass. One of the two solved it.
     

Share This Page