idleing problem/ oil pressure problem NEED HELP FAST!

Thread in 'Technical Questions' started by cazper6, Mar 7, 2010.

  1. cazper6

    cazper6 New Member

    Joined:
    Mar 7, 2010
    Posts:
    5
    Likes Received:
    0
    I have a Nissan Silvia S-14 1993 sr20de(t). I am having some idling issues. my car slowly rev's up higher and higher as its ran longer. in about 2 minutes it is running at 2500 rpm's i have untightened my tps to adjust and if i turn my tps up and hold it, the throttle goes down to normal idle around 1000 rpms but then automatically adjusts itself back up to 2300 or 2500 around that area. it seems like the ecu needs to be reflashed as it does it automatically every time. and it gets worse as the car gets more warm. also my oil pressure drops as my oil temperature will raise. maybe after 10 min. of driving it would be to high to drive any more safely. If you need. Email me at [email protected]
     
  2. jabran200

    jabran200 Member

    Joined:
    Mar 3, 2007
    Posts:
    623
    Likes Received:
    0
    oil pressure drops as oil temp rises because the oil becomes thinner when hot therefore less pressure.

    Look at the idle possible for the revs changing.
     
  3. cazper6

    cazper6 New Member

    Joined:
    Mar 7, 2010
    Posts:
    5
    Likes Received:
    0
    Right, but this drops drastically.. im not forsure what it is in american but i normal am setting at 60 on my oil pressure .. and its never dropped this bad. but in about 10 min of driving it will drop to about 30... after 20 min of driving my oil pressure light is on. by then my oil temp alarm is going off. and sometimes when i am driving the car will start loosing power.. for example. if i am in first just cruising .. it will start bogging like im at to low of revs for the gear.. like its about to die.. bumping up and down. even tho im trying to give it more gas. like its not getting fuel. but that cant be the issue cause ive already upgraded the fuel pump to a better one a few months back and it wasnt doing this problem. but if i am setting there with the car on.. the idle will start to increase. and if i push in on the gas while setting to rev up.. my idle will increase after i let off the gas. for example of that.. if i am idleing at 1700 and give it gas to 3500 rpms.. when it idles back down it will be at 2000 and if i do it again it will idle down to 2200. and so on til its at a really high idle.
     
  4. redwood

    redwood Member

    Joined:
    Sep 11, 2008
    Posts:
    139
    Likes Received:
    2
    with regard to high idle have you had any work done on the engine lately which could have disturbed the vacuum hoses or the sealing of the plenum? check all the vacuum hoses and make sure they are not cracked and are in order. Also check for air leaks on the intake side of engine.

    My oil pressure drops from 5 to 2 on the gauge in 10 mins as the engine reaches operating temperature, however if I rev hard it goes back upto 5. You could have a dodgy pressure sender or gauge. Is the car overheating and does your water temperature gauge go into the red?
     
  5. cazper6

    cazper6 New Member

    Joined:
    Mar 7, 2010
    Posts:
    5
    Likes Received:
    0
    yes the car does over heat and the water temp does go in the red.
     
  6. redwood

    redwood Member

    Joined:
    Sep 11, 2008
    Posts:
    139
    Likes Received:
    2
    if the car is overheating then this could affect the idle. is there any mixing of water and oil, do the water pipes go hard, is there smoke or steam out of the exhaust and is it using excessive water or oil.
     
  7. cazper6

    cazper6 New Member

    Joined:
    Mar 7, 2010
    Posts:
    5
    Likes Received:
    0
    the car doesnt start to over heat until after its been drove for a few. the idling problem is there from the start
     
  8. redwood

    redwood Member

    Joined:
    Sep 11, 2008
    Posts:
    139
    Likes Received:
    2
    my main concern would be the low oil pressure and overheating as this sounds serious, blown head gasket, weak oil pump or bottom end bearings, the high idle will probably be something silly.
     
  9. cazper6

    cazper6 New Member

    Joined:
    Mar 7, 2010
    Posts:
    5
    Likes Received:
    0
    yes that is my main concern but this has been bugging me so bad. i believe a oil pump will fix the problem with my oil pressure and oil temp. there is a bit of oil all over the front oil pump cover tho.. think maybe a blown head gasket?.. more than likely.. i will be changing both of those at the same time.
     
  10. redwood

    redwood Member

    Joined:
    Sep 11, 2008
    Posts:
    139
    Likes Received:
    2
    If you are doing head gasket and oil pump then I would remove engine and inspect and measure the bottom end as well, before buying any parts.
     

Share This Page