jzx100 ect light flashing

Thread in 'Technical Questions' started by Miltonmango, Feb 13, 2021.

  1. Miltonmango

    Miltonmango New Member

    Joined:
    Sep 30, 2019
    Posts:
    9
    Likes Received:
    0
    Location:
    Sunshine Coast
    Hi all,

    Until recently i have found that on the occasional start up my ect light flashes every two seconds for about 30 seconds and then goes away. Tonight on my entire drive home from work it stayed flashing for about 15 minutes. I have checked for codes and it has thrown a 8 and 9 or 89 however the engine light doesn't flash, only the etc light does. Is there any way to read these ect codes? I have a suspicion its gearbox related as it slips from time to time going into overdrive. Anyone had anything similar before or can point me in the right direction that would be great. Car is a 96 jzx100 auto.

    Cheeeers!!
     
  2. Roofless_

    Roofless_ Active Member

    Joined:
    Apr 28, 2019
    Posts:
    126
    Likes Received:
    29
    Location:
    Sevenoaks
    leaky capacitor on the ECU could be the issue.
     
  3. Miltonmango

    Miltonmango New Member

    Joined:
    Sep 30, 2019
    Posts:
    9
    Likes Received:
    0
    Location:
    Sunshine Coast
    @Roofless_ Have checked that already and it looked fine. I found a manual for a a340 for a 2jz and all i can seem to find is that the code 89 is for the trac ecu which im unsure if it is relevant in my car. I cannot seem to find any information anywhere about the etc light flashing in jzx100's.
     
  4. EMAGDNIM

    EMAGDNIM Member

    Joined:
    Mar 27, 2009
    Posts:
    89
    Likes Received:
    11
    Location:
    Toronto, Canada eh!
    The traction control ecu probably has bad capacitors. It’s going to do that till it’s fixed. Either pull the second plug on the throttle body, or fix the ECU.
     

Share This Page