Low idle, runs rich hesitant throttle

Thread in 'Technical Questions' started by Kyle k, Jan 24, 2017.

  1. Kyle k

    Kyle k New Member

    Joined:
    Jan 24, 2017
    Posts:
    3
    Likes Received:
    0
    *** ALL HELP APPRECIATED *** ( if you can find my problem i will e transfer 100$ ) have a 2jzgte out of an aristo auto ecu and i cannot seem to get it out of limp mode.
    Cold start is very hard cranks and cranks, idle dropped down to 500rpm and if you hit the gas it will want to bog out on you, afr is around 11 11.5, cuts at 3k rpm . ( car has sat for a few years it ran fine before, so there is old / shitty fuel in it, swapped out rear ends did the clutch and then this )







    What i have done
    New tps ( old one was shot )
    Different coil ignitor
    Different map
    Tested IACV
    Tested cam sensors
    New Coil pack connectors
    No vac leaks
    (There is more i am missing cannot list off the top of my head )
     
    #1 Kyle k, Jan 24, 2017
    Last edited: Jan 24, 2017
  2. Kyle k

    Kyle k New Member

    Joined:
    Jan 24, 2017
    Posts:
    3
    Likes Received:
    0
    Also car is all stock besides walbro 255 pump, aftermarket exhaust and Greddy BCC
     
  3. Ikeaaxel

    Ikeaaxel Member

    Joined:
    Sep 19, 2015
    Posts:
    79
    Likes Received:
    6
    Put fresh fuel in it before you waste your time doing anything else
     
  4. thenextdk

    thenextdk Member

    Joined:
    Sep 11, 2010
    Posts:
    642
    Likes Received:
    0
    Location:
    Herefordshire
    Tried cleaning maf?
     
  5. Kyle k

    Kyle k New Member

    Joined:
    Jan 24, 2017
    Posts:
    3
    Likes Received:
    0
    Dont think the fuel is the full issue im sure something else is going on, No maf sensor on this just MAP on intake
     

Share This Page