S13 CA18DET T28, laaaag....

Thread in 'Technical Questions' started by Minimoke, Mar 6, 2018.

  1. Minimoke

    Minimoke Member

    Joined:
    Oct 24, 2014
    Posts:
    264
    Likes Received:
    6
    Location:
    Chelmsford, Essex
    Hey all,
    Bit of a weird one. And I'm thinking it's going to be a leak somewhere. But I'd appreciate a few experienced hints.

    CA with a T28, 3" exhaust, Apexi cone inlet and Horsham stage 2 chip. Electronic Boost Controller.

    All of a sudden it's started boosting really late. Hovers around 3-5psi up until like 4.5k-5k, then smashes up to 13+. I've tried working with the duty/gain on the boost controller and it doesn't have an effect on it. It's also had a high idle in places even when the engine is hot. I had the intercooler pipes off the other day to fix a water pipe, but everything went back on tight. Would it reach full boost if it had a leak? Or is this more likely a vacuum leak somewhere else? Thanks in advance.
     
  2. Chunky Nugget

    Chunky Nugget honkeytits!!

    Joined:
    Feb 16, 2006
    Posts:
    1,858
    Likes Received:
    12
    Location:
    Aldershot
    Sounds to be an air flow issue. check the manifold for leaks, check the vacuum lines and the intake pipe to the turbo. Ideally you need to smoke test it, but you probably don't have the kit, but check that first. Check all the lines on the boost controller too.
     
  3. r3k1355

    r3k1355 Well-Known Member

    Joined:
    Nov 8, 2007
    Posts:
    3,409
    Likes Received:
    136
    Boost/vac leak or dodgy boost controller are most likely
     
  4. Minimoke

    Minimoke Member

    Joined:
    Oct 24, 2014
    Posts:
    264
    Likes Received:
    6
    Location:
    Chelmsford, Essex
    Cheers for the reply mate. I should also mention that the other week, the bar on the wastegate popped off and jammed the wastegate open (internal wastegate). I had to give the arm a little thump to get it back, and ever since then it's rattled a bit when you come off the throttle. Instantly stops when you apply any throttle. I had a nose around the vacuum lines this morning but couldn't see anything untoward. And the idle seemed fine today, so I'm not sure if that was a red herring.
     
  5. Minimoke

    Minimoke Member

    Joined:
    Oct 24, 2014
    Posts:
    264
    Likes Received:
    6
    Location:
    Chelmsford, Essex
    Sorry dude, I never saw your reply. I'm gonna have a closer look at that side of it yeah. I haven't got a smoke test kit no. Fingers crossed I find it. Cheers.
     
  6. Minimoke

    Minimoke Member

    Joined:
    Oct 24, 2014
    Posts:
    264
    Likes Received:
    6
    Location:
    Chelmsford, Essex
    Well I wound in the wastegate 2 turns and it's fixed the rattling and totally transformed the car. Odd that it was pulling fine and slowly got worse though without me adjusting the wastegate before....Hopefully it's not going to keep making itself loose. Now bits full boost around 3500 and pulls hard to 7500 at 14.5psi. One happy chappy. Cheers for the replies guys
     

Share This Page