S14 sr20det no spark help!!!!

Thread in 'Technical Questions' started by Wayski, Nov 15, 2020.

  1. Wayski

    Wayski New Member

    Nov 15, 2020
    Likes Received:
    will try and keep this simple for you guys.
    bought an s14 that needed some work doing. i went through a puddle and the ecu got wet along with the relays by the ecu. the car drove fine and when i got to my house and turned it off it was all fine. i went to start it about an hour later and it wouldnt start so i left it til the morning. the car then started up but would only rev to 3k so i thought it would be maf so i tried a mates working maf and it didnt fix the issue. then the car wouldnt start again and i took ecu apart and saw it was wet so i have changed it out for an ecu that i belive has nats delete one it. the car still wont start. i have checked the basics. its getting fuel and intercooler is still all attached and fine etc but it is NOT SPARKING... i have tried new plugs and they are still not sparking. (i have pulled a plug out and left in coil and turned over and no spark) i have checked power to each coil and they are all getting 12v. so i have changed the ignitor from my other working s14 and checked for power and that is fine also. one of the relays by the ecu is now making a weird tap and buzzing sound. i have changed the relay multiple times and it is still doing it. i have no idea what else to look at can anyone help cheers

Share This Page