S15 front wheels fitment problem

Thread in 'Technical Questions' started by hotrod, Feb 17, 2019.

  1. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    Hi guys, I'm trying to finish my s15 and I've big problem fitting the front wheels! I've put 40mm origin fender, 3.5 camber, almost 0 toe and like 7.3 caster. Dw coilover and all the driftworks arms plus tein tie rod and rod end, 9-18 with 215 40 18. The wheels hit in a bad way the frint of the fender where it match the bumper, a lot more on the left side than yth right. Car didn't has accident or any damage in the frint. Any tips? How can you make it turnable without change the height of the car? @Starkey ?
    Dkf0L4z.
     
  2. tomsheen

    tomsheen Active Member

    Joined:
    Sep 5, 2009
    Posts:
    259
    Likes Received:
    33
    Location:
    Ireland
    One of the arms must be backwards that’s pushed way too forward
     
  3. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    I don't think, damn it will be a very stupid error, will check anyways, fact is that if I go down with caster I start hit on the rear wheels wheel .. there's people lower than me,why mine touch so bad?
    y9Uy5AO.
     
  4. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,765
    Likes Received:
    300
    Location:
    New Zealand
    Take a photo of how you've installed your castor arms
     
  5. Moejorrison

    Moejorrison Member

    Joined:
    Sep 10, 2013
    Posts:
    159
    Likes Received:
    5
    Location:
    Bristol
    lots of castor angle makes this happen, also just run more camber
     
  6. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    Here are some pics of the arms and coilover
    yJpGHrv.
    97Rk1VT.
    mUgKh1s.
     
  7. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,765
    Likes Received:
    300
    Location:
    New Zealand
    Well the caster arm install looks fine

    Check that you have matching caster arm / tension rod brackets. I believe R33/R34 ones are shorter IIRC and could be causing this issue. They are easy to unbolt and compare side by side. Failing that, take measurements of each bracket and compare

    Next check where the lower control arm mounts to the subframe and look for any signs of damage. Compare left to right, taking pictures helps. Measure from the the LCA mount to forward to the front cross brace.
     
    • Like Like x 1
  8. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    IveI did some measure and they look fine, when i did the alignement the 'data' where good anyways. Arms are for s14/15.. holy shit
     
  9. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,765
    Likes Received:
    300
    Location:
    New Zealand
    Hang on, how many bolts do you have going from the caster arm into the LCA? It looks from you picture only one

    Can you take a picture from under the LCA, and from above looking down on where the swaybar (aka anti-roll bar) and caster arm are mounted
     
  10. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    They have 2 bolt on the lca
    wcy82Al.
    OkFTmRf.
     
  11. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,765
    Likes Received:
    300
    Location:
    New Zealand
    Do you have the original caster arms there? If you fit those do the wheels fit the same way?

    Does the bonnet line up with the guards and headlights properly?

    Do you have the standard front guards? If so does the wheel sit in the same place?

    It's looking more and more like poor fibreglass guards
     
  12. hotrod

    hotrod Member

    Joined:
    Feb 28, 2005
    Posts:
    133
    Likes Received:
    2
    Location:
    Italy
    Mh.. yes I've all the original parts, the fender make me think they're kinda shit for sure. maybe I'll try to add some more camber and see if it make any difference.
    I would like to see some other s15 and know how much caster other guys run and how it look
     
  13. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,765
    Likes Received:
    300
    Location:
    New Zealand
    Adding camber won't make any difference in the slightest
     

Share This Page