Sr20det high idle issues

Thread in 'Technical Questions' started by shanedixons14a, Nov 29, 2016.

  1. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    Hi guys im in the process of finishing my s14a i bought it as a project and it was 80% complete . Basically when i started the car it woukd be at high idle then after 3-4 mins it would start hunting between 1000-4000revs i have done the following checked for boost leaks , cleaned maf tps and iac valve i have adjusted the tps sensor by ear to see if that help and it idled higher , i have unplugged iac valve and it made no difrence , unplugged maff and it idled high again , i then went on and turned the screw all the way in on idle control valve and it lowered it to a steady 2200 revs no more hunting but i cant getnit no lower any help would be good im so confused and have no more ideas iv also tried other things today i gave it full service , emptied all the fuel and put new in it checked pipes again the only 1 thing to say is where the fuel pressure regulator is theres a pipe that goes from it a vac pipe to the inlet , but theres also another pipe teed of from this is that normal? It runs to the bulk head under inlet manifold and doesnt plug into nuffin i have put a bolt in it to stop it sucking
     
  2. clonehunter

    clonehunter Member

    Joined:
    Dec 20, 2013
    Posts:
    35
    Likes Received:
    0
    just throwing some steps in here:
    crank angle sensor/timing ?
    coolant temp sensor?
    throttle body gummed up?
    and another vacuum check, chances to overlook something are high
     
  3. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    Throttle bodys perfect and clean , cas is a possibility havent tried that , will probs change coolant temp sensor for the sake of piece of mind (does read perfect on temp gauge though)

    - - - Updated - - -

    Would idle control valve cause this if bad ?
     
  4. clonehunter

    clonehunter Member

    Joined:
    Dec 20, 2013
    Posts:
    35
    Likes Received:
    0
    idle control is another thing, yes.
    def. check it!
     
  5. Ollie

    Ollie LOOSE!

    Joined:
    Apr 14, 2010
    Posts:
    1,696
    Likes Received:
    3
    Location:
    London
    Fucking with the TPS can cause all sorts of issues, did you actually set it back right?
     
  6. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    It was already playing up so i adjusted it to see if it made a difrence i havent set it back yet but it will be set bk tomoz , if i unplug the idle control valve it makes no difrence at all so im guessing that is broke to be fair
     
  7. BenRice

    BenRice Well-Known Member

    Joined:
    Apr 23, 2014
    Posts:
    1,760
    Likes Received:
    295
    Location:
    New Zealand
    The vacuum pipe that was tee'd into the vacuum pipe going to the FPR would have been for a boost gauge in the cabin I'd fathom. Make sure that tee'd pipe is blocked so there's no leaks

    Check the timing first with a good timing light
     
  8. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    Thanks mate yer thats what i was thinking because usually it goes from fpr to inlet without a t piece doesnt it from what i remember iv ordered a idle control valve to give it a try , gona set up tps tomorow so i no thats ok only problem is it will be idling even higher and jumping up and down iv set ut atm so the idle dropped a smidge im also going to make a boost leak tester so i can do a test at home my mate has already done it at his garage when i was ther but no harm in double checking myself just need to figure the size out so i can go and buy a pvc end cap that fits
     
  9. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    SO i done a test on the tps sensor today the reaults seem ok closed throttle was 0.42 open throttle was fluctuating quite alot from 4.4-4.7 and the live feed was 5.11 are these ok ? Car still ideling high though
     
  10. yogi bear

    yogi bear Active Member

    Joined:
    Jan 22, 2009
    Posts:
    3,126
    Likes Received:
    0
    Location:
    soufend innit
    Tps won't affect your idling.

    How complete was your car when you got it? Is the cold start throttle jacker intact and plumbed in?
     
  11. shanedixons14a

    Joined:
    Jun 30, 2011
    Posts:
    230
    Likes Received:
    0
    Location:
    lowestoft
    It was not far of bwing finsished i have adjusted the bolt underneath the throttle pulley iv screwed it all the way in and it sounds like its brought the idle down alot now sounds notmal but its now made the tps sensor chnage readings . When i trun ignition rev counter sits at 900 revs when i start it goes to 1800 so i think my rev counter is 900 over what it really is as it sounds right now cant be sure though its. Ot revving its tits off now
     

Share This Page