Turbo Altezza cutting out when warm

Thread in 'Technical Questions' started by WatkinsDW, Dec 4, 2015.

  1. WatkinsDW

    WatkinsDW Member

    Joined:
    Sep 7, 2015
    Posts:
    79
    Likes Received:
    0
    So Ive recently had an engine conversion done on my Altezza. Had old 3sge engine removed, with another 3sge engine put in with turbo extras. apexi ecu and handcontroller.

    The garage who has done it have managed to get it up and running sweet but only when cold. They said it revs up nicely and gets some decent boost until the point of it getting warm. Once the engine has warmed up they said it just dies down and eventually leads to cutting out. They have checked the usual things like plugs coilpacks leads and stuff for moisture.

    They did say when they originally turned it over the first time lots of fuel was dumping out exhaust so they reduced the fuel flow with the hand controller then got it running sweet. But like i said that's only when cold. Any advice would be great.

    Thanks
     
  2. Stavros

    Stavros Active Member

    Joined:
    May 17, 2005
    Posts:
    26,125
    Likes Received:
    9
    Does this garage know what they're doing?

    Dumping fuel out the exhaust, like black smoke or neat fuel?
     
  3. sparky_s13

    sparky_s13 Active Member

    Joined:
    Mar 12, 2012
    Posts:
    2,196
    Likes Received:
    3
    Temp sensor issue?
     
  4. WatkinsDW

    WatkinsDW Member

    Joined:
    Sep 7, 2015
    Posts:
    79
    Likes Received:
    0
    He said it was neat fuel. And he did check temp sensor seems fine. The mechanic said it cuts out at half way temp which is about 90 degrees. It idles okay at that temperature but when you press the accelerater it dies off.
     
  5. stichy

    stichy Member

    Joined:
    Feb 15, 2009
    Posts:
    615
    Likes Received:
    0
    Has it been properly mapped for turbo setup ??
     
  6. WatkinsDW

    WatkinsDW Member

    Joined:
    Sep 7, 2015
    Posts:
    79
    Likes Received:
    0
    Yeah. It was all mapped for the engine ready to just drop it. But thinking now that it may need new map.
     
  7. stichy

    stichy Member

    Joined:
    Feb 15, 2009
    Posts:
    615
    Likes Received:
    0
    But now the garage had adjusted the fueling again.

    So it needs mapping again.
     
  8. WatkinsDW

    WatkinsDW Member

    Joined:
    Sep 7, 2015
    Posts:
    79
    Likes Received:
    0
    Brilliant! I think your right, guess ill just have to get it mapped. He said it only cuts out at operating temp (90 degrees) when he tries to rev it when warm it just dies. Kinda like it just ran out of fuel.
     

Share This Page